Windows Installer

From WPKG | Open Source Software Deployment and Distribution
Jump to: navigation, search

Some installers (i.e. Adobe Reader or MS Visio 2007) will require a recent version of the Windows Installer (download).


Windows Installer 3.1[edit]

Silent installation package below:

<?xml version="1.0" encoding="UTF-8"?>
<packages>
<package
  id="windows_installer_3"
  name="Windows Installer 3.1V2"
  revision="1"
  reboot="true"
  priority="20">
  <check type="logical" condition="or">
    <check type="uninstall" condition="exists" path="Windows Installer 3.1 (KB893803)" />
    <check type="uninstall" condition="exists" path="Windows XP Service Pack 3" />
  </check>
  <install cmd='"%SOFTWARE%\msi\WindowsInstaller-KB893803-v2-x86.exe" /quiet /norestart' >
    <exit code="194" reboot="true" />
    <exit code="1603" />
    <exit code="3010" reboot="true" />
  </install>
  <remove cmd='"%WINDIR%\$MSI31Uninstall_KB893803v2$\spuninst\spuninst.exe" /quiet /norestart' />
</package>
</packages>

Windows Installer 4.5[edit]

There is a 4.5 version for Vista, XP and Server 2003 available for download in http://www.microsoft.com/download/en/details.aspx?id=8483

Is this right?

<?xml version="1.0" encoding="UTF-8"?>
<packages>
<package id="windows_installer" name="Microsoft Windows Installer" revision="4.5.0" priority="100" os="professional.+5\.1\.\d{4}" architecture="x86">
  <check type="uninstall" condition="exists" path="(KB942288-v3)" />
  <install os="professional.+5\.1\.\d{4}" architecture="x86" cmd='"%SOFTWARE%\Microsoft\windows\WindowsXP-KB942288-v3-x86.exe" /quiet /norestart' />
  <upgrade os="professional.+5\.1\.\d{4}" architecture="x86" cmd='"%SOFTWARE%\Microsoft\windows\WindowsXP-KB942288-v3-x86.exe" /quiet /norestart' />
  <remove os="professional.+5\.1\.\d{4}" architecture="x86" cmd='"%WINDIR%\$NtUninstall_KB942288-v3$\spuninst\spuninst.exe" /quiet /norestart' />
</package>
</packages>